X-Blades Retail & Demo (solved)

Having trouble playing a game, post here

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Sat Oct 17, 2009 2:27 pm

And its sure that the Kernel32.dll missing APIs: FlsAlloc,FlsGetValue,FlsSetValue,FlsFree nothing have to do with it?
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by BlackWingCat » Sun Oct 18, 2009 1:34 am

OldBoy2k wrote:Missing Exports:
Kernel32.dll - FT_Exit12,FT_Exit20,FT_Exit24,FT_Exit8,FT_Thunk,GetProcessFlags,K32Thk1632Epilog,K32Thk1632Prolog,
MapLS,MapSL,MapSLFix,OpenVxDHandle,ReinitializeCriticalSection,SMapLS,SMapLS_IP_EBP_12,SMapLS_IP_EBP_16,
SMapLS_IP_EBP_20,SMapLS_IP_EBP_8,SUnMapLS,SUnMapLS_IP_EBP_12,SUnMapLS_IP_EBP_16,SUnMapLS_IP_EBP_20,
SUnMapLS_IP_EBP_8,ThunkConnect32,UnMapLS,UnMapSLFixArray

One thing to discuss:There's also a winmm.dll installed on Windows 2000 but its much newer and got v5.0.2161.1 (MCI API-DLL).Does anyone know the difference between these libraries?With the Windows 2000 winmm.dll nothing happens.Only when copying the above 4.3.0.1998 to the binaries directory....is winmm.dll v4.3.0.1998 a WinXP only library?!?


I think that you try to use win9x winmm.dll.
All function are Win9x's one.
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by BlackWingCat » Sun Oct 18, 2009 1:37 am

OldBoy2k wrote:And its sure that the Kernel32.dll missing APIs: FlsAlloc,FlsGetValue,FlsSetValue,FlsFree nothing have to do with it?


They are Windows Vista functions.
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Sun Oct 18, 2009 10:13 am

Okay.

BlackWingCat wrote:But something wrong my setting.
------------------
CrashHangAnalysis.asp Failed 0x80004005 Could not open specified dump file Line 256, Column 12


Related the Debugdiag Crash dump file, do you want me to send it to you (40mb .dmp)?
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by BlackWingCat » Sun Oct 18, 2009 11:38 pm

Don't warry.
I got same dump file.

OldBoy2k wrote:Okay.
Related the Debugdiag Crash dump file, do you want me to send it to you (40mb .dmp)?
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Tue Oct 20, 2009 1:59 pm

Is there someone who can install the X-Blades demo on WinXP and profile - complete run - the game with Dependencywalker and upload the log in the forum? - this game freaks me out...
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by JH2k » Tue Oct 20, 2009 2:24 pm

OldBoy2k wrote:Is there someone who can install the X-Blades demo on WinXP and profile - complete run - the game with Dependencywalker and upload the log in the forum? - this game freaks me out...


I'll try this afternoon/night if no one makes it before.
JH2k
 
Posts: 140
Joined: Sat Nov 29, 2008 9:23 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Tue Oct 20, 2009 2:40 pm

Excellent.Just open the launcher.exe,start the game and profile the game.Then save as *.dwi.This way i can also look at the launcher APIs and libs.
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by JH2k » Tue Oct 20, 2009 7:47 pm

Here 2 dwi, one with the launcher.exe, one without (it is not needed to run the game):

With

Without
JH2k
 
Posts: 140
Joined: Sat Nov 29, 2008 9:23 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Tue Oct 20, 2009 8:20 pm

Thanks!Good work but i also need to have one DWI with complete startup of the game.Just open the x-blades.exe in Dependencywalker and then under "File" in the menu choose "Start Profiling".Select everything excluded/not including these settings:
- Clear the log window
- Log thread information
- Use full paths when logging file names.
- Log a time stamp with each line of log.

press OK.Then after the game loads up, exit it and save the dwi again.
Thanks
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by JH2k » Tue Oct 20, 2009 10:21 pm

Argh you are going to kill me :S

http://www.megaupload.com/?d=Q2O2YLUL
JH2k
 
Posts: 140
Joined: Sat Nov 29, 2008 9:23 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Wed Oct 21, 2009 2:22 pm

Hi JH2k,

do you have WMP11 (Windows Media Player 11) installed on WinXP or any WMP11 related codec pack?
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by JH2k » Wed Oct 21, 2009 3:20 pm

OldBoy2k wrote:Hi JH2k,

do you have WMP11 (Windows Media Player 11) installed on WinXP or any WMP11 related codec pack?


:shock: :?:

You got me there. What comes out of the box in a Windows XP SP2 installation? That is what I have, I think 9.

Wait, I'll check the WMP XP folder from here to see if the executable shows the version... 9.0. It is the ninth version.

The same I have here on 2K. And, talking about codecs, the pacakges of WMV9 codecs for the 6.4. But I think I didn't install this last one on XP.

Anyway, nothing of 11 here.
JH2k
 
Posts: 140
Joined: Sat Nov 29, 2008 9:23 pm

Re: X-Blades Retail (not yet solved starting crash)

PostPosted by OldBoy2k » Wed Oct 21, 2009 6:22 pm

Okay thanks.That helps with the most important question.

Which Foreceware/ATI driver is installed on XP and which PhysX version?Just seek for a file "PhysX.cpl" and "PhysXLoader.dll" right click properties version info.The forceware version can be found through seeking for "nwiz.exe",right click if you have nvidia card.
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: X-Blades Retail (we are getting closer to the problem!)

PostPosted by JH2k » Wed Oct 21, 2009 7:01 pm

Physx: not installed on XP
(neither 2k as I haven't compatible hardware)

Nvidia: 163.75 on XP
I still have the uncompressed installation folder on its partition. I also have checked now the nv4_mini.sys driver on winxp\system32\drivers and it is 6.14.11.6375 that corresponds with 163.75.
JH2k
 
Posts: 140
Joined: Sat Nov 29, 2008 9:23 pm

PreviousNext

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 0 guests

cron