Hellgate London MP error?

Having trouble playing a game, post here

Hellgate London MP error?

PostPosted by Nyxangel » Tue Mar 11, 2008 11:19 pm

Hi again, not sure whats causing this so i thought i would toss it out to the guru's

When I try to log onto the MP server it gives me the error "8-2544: There maybe a problem with your anti-virus or Firewall" funny thing is I uninstalled my anti-virus and firewall and am still getting it. So out of Curiosity I figured I would post this problem here because i am not sure if it is just me, Hellgate it's self, or the wrapper pack.

Any advice would be great ^.^

Thanks again
Nyxangel
 
Posts: 3
Joined: Wed Mar 05, 2008 11:07 pm

PostPosted by OldBoy2k » Wed Mar 12, 2008 1:41 am

Hi,two questions.Are you running the retail or the demo?Did you update the game with the latest mp 1.0.27.4101 patch?

Heres a actual discussion maybe that helps:
http://www.hellgateguru.com/forum/showthread.php?t=8366
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

PostPosted by Nyxangel » Wed Mar 12, 2008 7:54 am

Well i was an idiot with the patch but i have that installed now. and I am getting the same error but now the number is 8-2661. so to answer your questions, Retail, and patched. netsh winsock reset doesn't seem to work doesn't recognize "winsock reset" as a command. so yeah i'm confused. and I know its not my network because of the fact that my roommate can connect just fine on vista for hellgate london.
Nyxangel
 
Posts: 3
Joined: Wed Mar 05, 2008 11:07 pm

PostPosted by OldBoy2k » Wed Mar 12, 2008 10:45 am

Hi Nyxangel,

its difficult for me to help you with these kind of errors though however i found the same error mentioned at this site.Only one source to this problem.

http://appdb.winehq.org/objectManager.p ... ngId=17224

The best recommendation i can give you right now is to register at Hellgate London support forums and post your problem there if that above link doesnt lead you to a solution.When you register at Hellgate Forum and dont mention that you're running Windows 2000 they may help and fix that problem.

greets
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

PostPosted by OldCigarette » Sun Mar 16, 2008 3:33 am

Nyxangel and myself have been tinkering with this a bit, I figure I'll post what I've come up with incase anyone else is looking at this.

Going from the wine log we can see WSAIoctl fails for command SIO_GET_EXTENSION_FUNCTION_POINTER.
These are the functions it will try to load
WSAID_ACCEPTEX
WSAID_GETACCEPTEXSOCKADDRS
WSAID_CONNECTEX
WSAID_DISCONNECTEX

GetAcceptExSockaddrs & AcceptEx should already be available on win2k so it is just a matter of making sure WSAIoctl returns it. The rest of the calls are XP and newer only.

DisconnectEx would be pretty easy too.
However, for Windows 2000 or Windows NT 4.0 it is possible to call TransmitFile with a null file handle and buffers but specify the disconnect and re-use flags, which will achieve the same results.


ConnectEx is harder to implement. I've looked into doing ConnectEx a bit and have a fair idea of how to do it.

Trouble is we're running into trouble before this though, here is the log message from hellgate (you can find the logs here C:\Documents and Settings\<your username>\My Documents\My Games\Hellgate)
Code: Select all
22:50:47.281 Connection loop failed initializing state 1 while in state 0
Last edited by OldCigarette on Mon Mar 17, 2008 3:13 am, edited 1 time in total.
OldCigarette
 
Posts: 208
Joined: Sun Feb 03, 2008 6:35 am
Location: Qo`nos

PostPosted by OldBoy2k » Sun Mar 16, 2008 5:53 pm

OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

PostPosted by OldCigarette » Fri Mar 21, 2008 4:53 am

We are one step closer!

The other problem I mentioned in the previous post has been found. The problem is a call to ADVAPI32 CryptAcquireContextA for CSP PROV_RSA_AES. This is the Microsoft Enhanced RSA and AES Cryptographic Provider (Prototype) for encrypting data. The password and username seem to be encrypted with these before login but it could not do it so it would fail. More info on the AES provider can be found here.
http://msdn2.microsoft.com/en-us/library/aa386979(VS.85).aspx

I started to try to get the XP rsaenh.dll to work on 2k. I messed around for quite a while, but then I discovered the AES functionality is already there! It just needs to be enabled. In the v1_4 of the wrapper pack and on there is a AES_PROVIDER.reg key that will enable it. Tada now it is working!
http://oldcigaret.info/win2k/phpBB3/viewtopic.php?t=7

Now we get the same errors as wine!
Code: Select all
WSAIoct1 SIO_GET_EXTENSION_FUNCTION_POINTER GUID=0x25A207B9 failed, WSALastError=0x00002726
WSAIoct1 SIO_GET_EXTENSION_FUNCTION_POINTER GUID=0x7FDA2E11 failed, WSALastError=0x00002726


I've implemented basic versions but we still have troubles, stay tuned.
OldCigarette
 
Posts: 208
Joined: Sun Feb 03, 2008 6:35 am
Location: Qo`nos

PostPosted by OldCigarette » Fri Mar 28, 2008 9:05 pm

Last time I was a little brief on the current problem.

Right now we are running into the 8-2709 error from hellgate. It raises no errors in the error log unfortunately. So there is little to go on. I don't have a copy of the game but Nyxangel does, he's been very helpful and has been doing most testing for me while I look at the demo.

Till I get my copy of the game we can't go much further because I must try to trace this in the debugger. I've added DisconnectEx and ConnectEx implementations to WSAIoctl but I can't be sure I have implemented these correctly without debugging.

So till then we're stuck.

Cheers
OldCigarette
 
Posts: 208
Joined: Sun Feb 03, 2008 6:35 am
Location: Qo`nos

Re: Hellgate London MP error?

PostPosted by OldBoy2k » Tue Jan 27, 2009 1:07 am

Hi all,

just looked at Hellgate London (v1.18074.70.4256) with Dependencywalker again and found one tiny little "bugger" which got lost on the way.Also "MSS32.DLL" is needed to cover call "_AIL_mem_use_malloc@4"!

BR
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Hellgate London MP error?

PostPosted by BlackWingCat » Mon Mar 12, 2012 11:26 am

I released another wrapper solution "Windows 2000 Extended Kernel Project".

Hellgate work on Windows 2000 with kernel version 15.

Now English version and Traditional Chinese version are v13i.
English version and Traditional Chinese 's v15 are coming soon.
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: Hellgate London MP error?

PostPosted by OldBoy2k » Mon Mar 12, 2012 5:22 pm

Hey,good news. Do you know why the regular wrappers don't work and at which point they fail?

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Hellgate London MP error?

PostPosted by BlackWingCat » Tue Mar 13, 2012 9:48 am

The program's hackshield detected attached to user32.dll .
And blocked execute Program and terminate process.

If we use new solution, we can avoid the Checking CRC and Dll Placement programs.
OldBoy2k wrote:Hey,good news. Do you know why the regular wrappers don't work and at which point they fail?

BR
OldBoy2k
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: Hellgate London MP error?

PostPosted by OldBoy2k » Tue Mar 13, 2012 10:17 am

Okay, thanks. Can you share some more technical info?Are the caught API calls the problem?Is it limited to user lib only?Did you add and tried aclayers.dll with OldCigarettes Wrapper Kernel and ini with Aclayers = 1?

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Hellgate London MP error?

PostPosted by BlackWingCat » Wed Mar 14, 2012 4:08 am

Hellgate program hackshield checked kernel32 and user32.

I created patched Dll folloing on v13

ADVAPI32.DLL
kernel32.dll
msvcirt.dll
msvcrt.dll
ntdll.dll
setupapi.dll
shell32.dll
shlwapi.dll
user32.dll
Ws2_32.dll
WTSAPI32.dll

And added on v15

iphlpapi.dll
crypt32.dll
dnsapi.dll
uxtheme.dll

I have never touched aclayers.dll.

OldBoy2k wrote:Okay, thanks. Can you share some more technical info?Are the caught API calls the problem?Is it limited to user lib only?Did you add and tried aclayers.dll with OldCigarettes Wrapper Kernel and ini with Aclayers = 1?

BR
OldBoy2k
BlackWingCat
 
Posts: 75
Joined: Sat Mar 07, 2009 7:20 am
Location: Kanagawa, Japan

Re: Hellgate London MP error?

PostPosted by OldBoy2k » Wed Mar 14, 2012 11:12 am

Hi,

since you have the game installed already, could you pls test it with OldCigarettes wrapper and Aclayers=1 in wrapper ini?Pretty sure the cp works with aclayers C:\WINNT\AppPatch\aclayers.dll.

greetings and thanks again for the infos!
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Next

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest