Sonic 4 Episode I

Having trouble playing a game, post here

Sonic 4 Episode I

PostPosted by CastleBravo » Sun Apr 22, 2012 7:22 am

Hey everyone.

I've been using this wrapper pack for quite a while now, and it gets the job done wonderfully. However, lately I got Sonic 4 Episode I on Steam, and tried to use the wrapper pack with the game. After some tweaks and header modifications to make the application even start on Win2k, I could get it to run, but it just crashes for me when the window would appear.

So I'm wondering, has anyone managed to get this game to work?

Thanks.
Castle.
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Sun Apr 22, 2012 2:25 pm

Hi,

check if you fixed the following libraries:

Missing Exports:
XINPUT1_3.DLL
MSVCP100.DLL
MSVCR100.DLL
KERNEL32.DLL - DecodePointer,EncodePointer (probably not required)

for Microsoft Visual Studio 10 libraries MSVCP100.DLL,MSVCR100.DLL look here:
Win2kgaming: Advanced Fix Guide

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Sun Apr 22, 2012 7:09 pm

I got those off of DLL-Files, as it was in the guide, but now it says that msvcr100 isn't a valid Windows image. When I run it with the pack I got off of KDW, it works just like I said in the first post, crash.
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Sun Apr 22, 2012 8:18 pm

Hi,

please use OldCigarette's Kernel and create and upload the DWI and i will take a look.

Here's how you do it:
Info: Dependency Walker logs (= dwi file)

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Mon Apr 23, 2012 5:59 am

Okay, here's the link:
http://www.sendspace.com/file/94hpgh

What I meant back there, I should've been more speicific, is that I use the Redistributable package containing the latest msv* dlls that KDW made. I thought I had missing exports in those files, but according to the Dependency Walker I don't. I use the OldCigarettes wrapper.

Thanks.
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Mon Apr 23, 2012 4:03 pm

Hi,

please remove e:\games\steam\steamapps\common\sonic the hedgehog 4 ep 1\APPHELP.DLL if you added it and use the profile mode in Dependency Walker and upload this DWI again. See Part 2. Advanced error detection in Profile Mode in Info: Dependency Walker logs (= dwi file)

Thanks.

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Tue Apr 24, 2012 9:15 am

CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Tue Apr 24, 2012 11:27 am

Hi,

it seems to be rendering related DirectX Software rendering problem. Because of a first chance exception with a missing D3DREF9.DLL (strangely enough since its only a debugging helper :roll: ) try this library in your binaries directory of the game:
down-dll.com: d3dref9.dll

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Tue Apr 24, 2012 7:24 pm

It still occurs, seems like some functions are missing in the msvc* 100 dlls, as well as kernel32:
http://www.sendspace.com/file/azb01i
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Tue Apr 24, 2012 8:45 pm

Back to my last question. What happens, when you remove APPHELP.DLL from the e:\games\steam\steamapps\common\sonic the hedgehog 4 ep 1\ directory? Does it get replaced the next time you run the game?

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Wed Apr 25, 2012 6:18 am

It seems to have solved some of the missing exports, but the functions FlsAlloc, FlsGetValue, FlsSetValue, and FlsFree still can't be found, as well as IsTNT.

http://www.sendspace.com/file/sfzpfe
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Wed Apr 25, 2012 9:12 am

CastleBravo wrote:FlsAlloc, FlsGetValue, FlsSetValue, and FlsFree still can't be found, as well as IsTNT.

New Vista APIs, no need to fix.

Did you rename the Sonic_xp_save.dat?Can you pls upload the DWI of Sonic_vis.exe?
Sonic 4 Episode 1 update on steam
Hedgehog Day Update?

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by CastleBravo » Wed Apr 25, 2012 10:38 am

I haven't run Sonic 4 on this OS yet so there wasn't any .dat file to rename. I tried running Sonic 4's vista version, but it's missing an entry point in d3d9.dll, Direct3DCreate9Ex, I couldn't even profile it with Dependency Walker, it couldn't load any of the required dlls.

I don't know, could be some bug in Sonic 4 itself that causes this then, if it's not a problem with the wrappers.
Thanks for your help anyway.
CastleBravo
 
Posts: 12
Joined: Sun Apr 22, 2012 7:18 am

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Wed Apr 25, 2012 10:52 am

Hi,

please check your post box.

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Re: Sonic 4 Episode I

PostPosted by OldBoy2k » Sun May 27, 2012 9:21 pm

Hey,

did you get the game working?

BR
OldBoy2k
OldBoy2k
 
Posts: 1351
Joined: Fri Feb 15, 2008 5:10 pm

Next

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron